E36 325i problem with keeping the speed at one level.

Say I'm trying to drive the car at 60kmnh, the car speeds up great and gears down great, but I have a problem with keeping the speed at one level. The car either wants to speed up or gear down. In order to do the
speed limit I have to let go of the gas slightly, let it gear down little bit and then speed up little bit. Its not really bad but it sould not be happening. The following things have been done to the engine: ACschnitzer Cams, Motorsport throttle body, chip, headers & full custom exhaust. Does it need to be remaped? Maybe oxhygen sensor? or maybe some other sensor???? help...
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.bmw / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You are probably trying to set a cruise speed just at the change point for the auto box.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Changing a cam profile certainly requires re-mapping. But then the 'chip' should do this if part of a package. If you've simply picked the bits at random that's the problem.
--
Small asylum seeker wanted as mud flap, must be flexible and willing to travel

Dave Plowman snipped-for-privacy@davenoise.co.uk London SW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.