igniton switch e39

The electrical system in my 98 528i is going crazy !
The radio works then stops with half the display on then the whole thing is off then on. Seems the radio keeps shuting off and on by
itself. When the radio is off other items go crazy like the turn signals... the light in the cluster will not work or click bur I see the light bulb flashing. When the radio turns itself on the turn signlas are fine...I did hear a click in the coming for the glove compartment I think? when the radio died this morning...the time clock is on then on then off on the radio..anyway..the door adjar symbol from the cluster would not go off when I closed the passenger door eventually it did go off....weird weird weird... when the radio decides to be "ON" everything works !
I did change the ignition switch back in Sept when the car had similar symptoms ...back then the srs ligt was on and the radio would shut copmpletly off and on....no xmas lights show on the radio..
Someone things there might be something wrong with the IBUS?
Thanks in advance for your help !
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

I wouldn't necessarily blame the radio for this. My first guess is that you have a bad electrical ground somewhere that is affecting the radio as well as a number of other things.
9 out of 10 of "weird-and-wacky" intermittent electrical problems are caused by bad grounding.
--
Dan.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.