Wipers AND Door Locks

About three days ago my wipers simply stopped working. I have checked the fuse and it is fine. The motor is silent when I turn it on so it does not
sound like a problem of disconnected linkages or damaged gears. Then, last night when I tried to lock my doors all of them would not lock. In fact, just the trunk would lock. So it sounds like I might have two electronic gremlins at work. Am I ok to disconnect the battery to see if that will do anything?
Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Check the relays
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Where would the relays be? And what do they do? Thanks!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
HooKooKaDoo wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
what model do u have...E34....525i...what year?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
HooKooKaDoo wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
what model do u have ..E34...i have had same problem
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a 1998 528i.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
with this model E39...the electrical ignition switch could be dropping voltage at contacts internally...if you can duplicate it , it can be checked with a volt meter... switch is located on the left side of steering column under the panels behind steering wheel...
i hope this helps your diagnoses...let me know...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When I saw I had to take apart the area under the steering wheel I opted to take it in for service because I needed some other things done. The good news is that it was the relay as you suggested and the labor was only $30 bucks over the cost of the relay which for me was worth it. Thanks for your help.
JB

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.