Erratic Xantia

My 1997 2.0 16v Xantia works well except that at engine speeds between 3400 and 3600 the engine appears erratic, as if it is only firing on two cylinders. It has been doing this for over two years and is only a problem
when overtaking. My local garage has been unable to trace the fault but suggested it may be the coil pack. I am reluctant to take it to a Citroen garage to have checked on their computer at their costs. Has anybody else had this problem and know the solution please.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Our car seemed to have a ghost pressing the gaspedal now and then and when you hold in the clutch it went from 1000 to 3500 rpms for no reason. It was also hard to start. I don`t have the english word for this part. I think it`s "idle running" or something, if that is the word it, it could be an "idle running controller" (now that is directly translated word for word...lol). Anyway, they changed it and now the car is better than ever. This was a 99 xantia 1,8 Exclusive. It was also a very cheap part. £120 in norway, work included, so I guess you`ll get it even cheaper in any other part of the world...
Frank
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Site Timeline

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.