2002 instrument cluster GC

The last few mornings when starting the mini-van (2002 GC ES with 3.8L) all of the gear shift indicators are lit with a green block around "P", "R",
"N", "D", "2", and "1". It also showed this behavior the other afternoon while running some errands.
If I shift to reverse (R) or beyond only that individual mode is lit (normal), and then back to Park (P) only the P is lit.
I have run the instrument calibraton with no effect. I also flipped the ignition switch to check for codes and it returns dolely "done".
Any ideas what is going on?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It could be a faulty PRNDL switch on the valve body in the transmission or a communication fault.
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The transmission has been torn apart several times, would this lean towards guessing one of the above over another?
Also, the power sliding doors won't operate when all are lit, I assume that fits the scenario. Wouldn't the communication fault throw a code? Or is it just a code not retreivable via the igition toggling and the Dealer or other fancy OBD-II reader is required.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

is at. The doors are not supposed to open in drive or reverse. Have the trans module and PCM scanned for any fault codes.
Glenn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.