2005 Grand Caravan (Stalls)

I have a 2005 Grand Caravan with 15K miles. Been to the dealer, twice, for this problem....and, of course, the problem never replicates itself for
the technician....nor, are there any stored codes for them to reference.
The caravan will completely shut-off, for no apparent reason, while stopped at a light. This only happens occasionally....I drove the van from VA to FL and back a week ago and the problem NEVER occured....but, then, today, at a light, everything shut off---as if I turned the key off. Had to place the van in park---and it restarted right away (as it always does when this happens).
Originally thought it might be the cd changer....as it only happened when playing CDs....but, today the radio was on (not CD).
I'm stumped, and the dealer won't do anything---because when I bring the van in....everything is fine. Any ideas what might be causing the stalling??
Thanks....Regards, John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The is a reflash out for a rough idle problem that may pertain to your problem. The dealer needs to connect the scan tool to see if any updates are available for your vehicle. The other thing they could do would be connect what we call a co-pilot up to the vehicle. You drive the vehicle and when the problem happens you push a button and it snaps a shot with so many seconds before and after the problem occured. The technician then downloads and reads the data off the PC. Just curious...what dealer did you take it to?
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Glenn
Took it to Greenbrier Dodge in Chesapeake VA. Both times I took it, the van ran fine. They drove it 8 miles the first time and 12.5 the second time (I reset the trip computer before turning it in....just to make sure they actually "drove" it). However, as I stated below, I drove the van to FL and back...and, for 5 straight days while in Florida, and not one hint of trouble.
John

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

up
off
Well at least they put fourth effort to try to duplicate the problem. Most places would only drive it around the block. But either way the next time you go to the dealer have them check to see if there is an update for the engine controller.
Glenn Beasley
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'm commenting on this one late but are you by any chance running citgo gas in it? My Dakotas (both my 98 and 2000) will not run that crap for some reason. Rough idle, stalling when stopped for lights or signs. If I run any other fuel they work fine but not citgo for some reason.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hmmmm, I do run CitGo gas in it...hmmmm, I'll try another gas station for a couple of fill ups and see what that does.
John

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.