SRS light on - '91 Stealth ES

Today, had some electrical problems - car died while driving on the freeway. Turns out that the problem was the + battery clamp - actually came lose while driving. Anyway, while trying to figure out the problem, several
times I was able to restart the car, only to have it die again with a complete power failure. Each time it started to fail, there was a bunch of clicking under the dash - relays or something. Fixed the battery connection problem, and now my SRS light remains lit. I've been through several starts and warm-ups - still lit. Any suggestions on what I can check? Anyone else ever see this? Thanks - Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You would need to find out what code has been set by a scan tool
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had a '93 with a similar problem. The SRS has two power sources, and if either fuse is blown the lamp will light. I don't remember which circuits supply power, and I don't have my service manual handy to look it up. Just check for power on both sides of all fuses to see if one is blown or fractured.
HTH Gyz

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.