transmission

I have a 1996 Buick Regal. And you can feel the transmission go into gear and the motor bog down. But when you give it gas it goes no where, but you
can feel it trying to pull. I have checked the fluid and to see if the brakes are locked up and they are not. I have jacked up the car and the wheels turn, and in any gear one goes one way and the other side goes the oppsite way. I am lost. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Last time I checked Dodge and Buick were from different manufacturers. CUL8R!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
89DAY wrote:

Yup. You're lost. You have a Buick. This is a DODGE newsgroup.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yes I have relaized I wrote the message in the wrong place.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I would guess a differential problem given your description but I'm not an expert.
CD

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
you may have a busted planetary in the transmission, or the direct clutch may be stuck.
see your local Buick dealer today!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.