97 Dodge RAM 1500 cruise control

I have 97 Dodge RAM 1500 Extended Cab PU (5.2L) and really enjoy it but my cruise control has apparently went out. The cruise control button in the steering wheel will come on but it will not engage. After about
1 minute, the system will turn itself off.
I use cruise control allot and was wondering, is there a module that I can replace or a vacuum hose that I should look for. Forgive me, I am not a mechanic and any information will be appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My '96 had the same problem and it turned out to be a severed vacuum hose beneath the battery tray. Minimal cost; replaced it myself. Hope this helps.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had the same condition Ralph did on my '96 5.9. I did not replace the line though. It broke off at the connector right under the battery tray. I just cut and removed the bad section, stuck it back in and taped it real tight with electrical tape. It's been perfect ever since. My symtoms were a bit different than yours though. Sometimes it would engage but it would never hold the correct speed as it would vary within about a 20 mph range. Usually it would not engage though. I never had the light go out on me though.
Steve
ntguyccs wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.