Tuning v6 3.4l

Hi Guys
Am new to the group having just acquired a clean 1993 Camaro fitted with the above engine and auto box. Seems to run well enough and the custom stainless
exhaust someone has had fitted sounds awesome.
I am based in the UK and have a couple of questions:
1 Can someone give or point me in the direction of good advice for uprating this engine, as quite honestly 160bhp seems miserly, obviously not looking to spend a fortune but finding another 20 or 30% for reasonably small outlay would be appreciated. 2 The service engine light comes on once engine is warm, oil pressure is high top of guage and water temp is low around bottom third of guage unless in traffic when it climbs to the middle. Oil & filter was changed 1000 miles ago. There is a suggestion that the car has had the Cat removed would this cause the light to come on??
All views appreciated
T.I.A. Clive
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

V8's generally get 10-15HP with a good air filter kit, but I'm not sure if that's similar with V6's or relative with size.
Headers would probably be the next bet (with me anyway :-> )
There are a list of free mods around(I've got a '95 Z28 so not sure what would apply to a v6, probably most, but I've refrained from most of them due to drivability issues).

problems with my car I was made to have one fitted (and charged for:-< ) to sort my ignition/emmissions problem. As far as i'm aware '95 and later cars are supposed to have one. I will remove mine again at some stage when time permits.
Have you scanned the car for error codes yet ? How soon does the light come on? after 2-3 minutes? Have you checked the fuses under the hood ? . Mine suffered an AIR pump fuse blowing frequently, sorted now though.
HTH
--
Mitch - 1995 Z28 LT1 M6
terminal snipped-for-privacy@sand-hill.freeserve.co.uk
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Opposite end of country, down south west in N.Devon.
No haven't had it scanned yet I only picked it up Friday afternoon after some complicated vehicle swapping, thanks for rest of advice.
Clive
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.