98 Taurus Speedometer issue

I was driving my '98 Taurus on the highway today and all the sudden the speedometer started going crazy and jumping everywhere. Also the car would accelerate and backfire. I was pulling over when all the sudden the
speedometer gave one final lurch and broke and is now stuck 0. My car is still backfiring and sputtering too. Does anyone know what this could be from?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'll hazard a guess at the vehicle speed sensor. Used for speedometer, as well as the PCM (powertrain control module) to determine shift points, and other performance information, since it isn't getting accurate reading, it can't figure out some of the settings. Does it idle and rev fine when stopped?
Another possibility is something exploded in the transmission.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
WARNING: If you have an electronically controlled automatic transmission, get the vehicle speed sensor fixed immediately! The inability to properly select functions causes overheating within the tranny, and will destroy it very quickly. If you must, drive short distances only - and manually shift the tranny. This is what my local Ford repair shop told me when my 97 Mercury Sable had a broken speed sensor, and I confirmed it with several other experts including a local tranny shop. It is not good to drive in this state.

would
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.