Escort tailgate/alarm...

I can't seem to open/unlock my boot on my 94 Escort 1.6 L, without the alarm/horn going off.
What on earth can I do. I've recently fitted a new driver-side door lock,
could I have messed something up?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actually add to that, I suddenly can't open ANY door without the alarm going off.
The red LED next to the clock remains constantly on.
Please help, I can't drive it or do ANYTHING with the battery connected as the alarm goes off!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Kontaminator wrote:

On a more recent Escort, the THEFT light stays on (and the "alarm", such that it is, remains armed) until you unlock the driver side door with either the key or the remote. I'd say it's a pretty safe bet you have disconnected something from the driver side lock, and the alarm isn't seeing that door being unlocked.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Spot on, I had the drivers side door panel off again, and the alarm switch clipped on to the lock wasn't connected to the release lever properly. All okay now - PHEW!
Cheers.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.