FORD FOCUS COIL PROBLEM?

Apologies for the vagueness of this question but last week my ford focus was spluttering while running and i was advised to have a diagnostic check to try and find the problem. The chap who done this advised me it was only
running on 3 cylinders and suggested replacing the coil, leads and plugs. This was done and everything seemed to be fine until today when the same thing happened. This time it appeared to be a different cylinder not working. I wondered if this was likely to be a faulty coil or another problem, any advice greatly appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You may have to change the connector and wires that go to the coilpack. Ford has a repair kit. The wires fatigue and break inside the casing causing a misfire. This is what happened on my 2.0L Zetec. Good Luck
BLACKHORSE68 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
hey myjob, I was wondering if there is a website or specific autoparts store where I can get the repair kit for connectors and wires that go to the coilpack. I ve been trying to find the it like crazy myob wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.