1990 Buick Century, Rough Idle Question

I just bought a 1990 Buick Century from a friend. The car has 64,000 miles on it. I knew the following when i bought the car (for 500.00)
When you stop at a red light, if the car is hot, the idle gets a
little rough where you have to rev the engine a little....
After driving the car, and you put the car into park the engine idles even rougher...
Any clues what could be causing this...
Last year the car had the fuel injectors cleaned, the gas filter replaced.
3 months ago the radiator was replaced
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Which engine?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The engine is the 3.3liter v6
On Fri, 21 Jan 2005 14:30:35 GMT, aarcuda69062

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
That model has OBD1 so reading the onboard computer is the easiest. If I was guessing, w/o a lot of money to wate, I would go to a parts store that reads the codes free or even buy a code reader for less than 100 bucks and read it myself. It could be lots of things, but EGR system and O2 sensor spring to mind. Vacuum lines off or cracked, who knows? Just Tough to say on a car that has had service by anyone and is that old.
good Luck
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.