87 GM 3.8L Revs at startup

My baby Bonneville has an odd behavior, when you start it up in the morning when it's cold it just revs like crazy! up around 2K! If you put the ac on, it quiets the thing down a little. Once you drive for 5 minutes, if you
put it in park, it idles normall at about 1.1K or whatever.
Check the error codes? Is it a choke? It's fuel injected, there is no choke! some sensor or other? How do you test this?
Help, my Bonnie lies over the tachdometer...
-b
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check your TPS voltages. I don't remember off the top of my head, but I believe idling the TPS should read about .5 to .7 Volts. If you have a scanner which displays TPS percentage, ignore it. The computer correlates 0% to the voltage present when you start the car.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
.45 to .55 on the Tps, check the coolant sensor for correct temp readings, clean the throttle body, pull the IAC and check for excess carbon and/or the shaft worn.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
dp wrote:

EGR system is likely in bad shape.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.