Civic transmission

Hello,
I have a 95 civic and the auto transmission seems to be acting funny. It only has 78,000 mi. I had the trans serviced last year. It seems to
accellerate a bit slowly with it sticking it 1st gear a bit too long. Also, when it is first shifted into drive it seems to slip a bit. I checked the fluid level it seems fine and isnt burnt. Just curious if this is a common problem on this model or any other info.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Don Moore wrote:

---------------------------------------
If 'they' filled your Honda tranny with anything other than Honda Z1 ATF, you'll have to drain-n-fill it three times (with the correct stuff). If you've been climbing any hills with the wrong stuff in it, you might be needing a new tranny. Read these TSB's to see if any apply to you: http://www.tegger.com/hondafaq/tsb/civic/index.html
'Curly'
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

It
Also,
the
common
I hope not. I had it at a dealership to service it, so I hope they used the right fluid. Thanks for the service bulletins.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.