2001 Tiburon spudders and lose of acceleration.

I was driving home today when I came to a stop light on a somewhat step slope. When I went to accelerate, there was a loud BANG and that was it. I drove about another 5 miles when the car started to spudder quite loudly
and I lose a mass amount of acceleration. 2 seconds later the "Check Engine" light blinked the rest of the 15 miles home. I was scared to drive because of the spudder and the lack of acceleration. I continued home and when I stopped in the drive way the car idled but spuddered lightly. It was dark so I couldn't really check anything. Can someone please help!?
2001 Tiburon, 52,000 miles, Manual.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

So.... there was a loud BANG, something was obviously very wrong...

...and you drove another 5 miles?????????

And then, as things get worse, you continue to drive another 15 miles???????

Yeah - do yourself a favor and get rid of your car. You shouldn't be driving a car.
No idea what your problem is, based on this description, but you should do nothing more than take your car to a competent mechanic and let him repair it.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
A flashing check engine lamp is an indication of a misfire. Hopefully it's a simple secondary ignition (plugs, wires, coil), but the loud bang suggests you may have a major engine failure.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.