99 accent obd service port

I got a 99 accent in for service that has a check engine light on, but can not find the obd service port. I looked for over 1/2 hour, but can not find
it anywhere. can someone shed some light on the location for me??
thanks, Tom
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

straight back - towards the firewall - from the headlight switch on the extreme left side of the car. It might even be in the fuse box - if there is one - on the left side of the car near the door hinge.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ok, thanks it is not in the fuse box, i looked there already. i will check on the firewall.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
found it! thanks. it was behind the headlight switch, but not under the dash like i thought. it was IN the dash,facing down, so i never saw it till i was getting out from looking under the dash. DOH!!!
and there was no codes present, so i just turned the light off, and called the girl to come and get it. told her to drive it around, and if the light came back on to bring it back and i will try again.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've seen this occur before where the TCM requests the check engine lamp. If it comes back, make sure you read the transmission codes as well.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.