1986 420 sel fuel pump relay location

My dad has an '86 420 SEL which starts and then dies. He read on other forums online that it might be the fuel filter, which turns out it's not. It might be the fuel pump, which I read you have to get 2, or it
mught be the fuel relay pump and I would like to know where the relay pump would be located. We looked, but couldn't tell which one it was. It died at my Grandmother's house and he had the mechanic look at it to see if it was the fuel filter. We were hoping it was, but the filter is practically new. Anyway we had my Grandmother's car and took it back over there to see if we could find the fuel pump relay. No luck, but my dad started the car and it started right up. We made it home and then he tried to start it again and no luck. Maybe it will start agin when the engine's cold. Hope someone can help here. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fuel pump relay is located in the fusebox.. the biggest black relay unit... a bit bigger than a cigarette box... and has the work "Kickdown" on it... on the side, there is a date stamp... if it is the same year as the car, it is definitely bad.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
86 and up is outside the fuse box. On the rear wall between the brake booster and the BIG ABS control, next to the KLIMA relay.
[81-85 was in the fuse box]

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I think we found the fuel pump relay. How can you tell if it is the culprit? tried to start it a little while ago and it sounds like it wants to start, but nothing. If we're able to get it to the mechanic, he can test the fuel pumps and prob. the relay I guess. Thanks for the info Karl wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I told you to look at the date... it is that simple.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
mooky wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.