1994 E420 running rough after 15 min---and overheating issues---- Resolved

Here's a follow-up..... When car ran rough I attached a timing light and checked each single spark plug wire (from front of engine leading to distributors) and noticed intermittent firing from wires leading to
left side distributor. Took cap off and notice a crack on outer housing. What was happening was after a few days condensation would build up inside cap because moisture would get inside and after 15 minutes or so the condensation would drip down to the contacts shorting the distributor creating a rough operation and also my overheating heating problem...Car ran fine if I ran it twice a day because the heat kept condensation at bay. Cap contacts also had a build-up/ corrosion which I think caused the overheating because of weak spark to 4 cylinders of 8.....
So, when your car is running rough try the timing light check above, it might point to a specific electrical issue: bad spark plug, distributor, wire, etc...and which one
Aloha, Derf
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the information. What we really need when searching this archive is confirmed diagnosis/solution.
You must feel proud for this is your first resolution of the new year :-)
Derf-E420-94 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.