2001 ML320

Does anyone know a way to get a softer ride in a 2001 ML320 with 27,000 miles. Great engine suspemsion etc, but hard on bumps? Thanks

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 02 Nov 2003 12:40:25 GMT, "michael m. petrone"

Trade it for an S class?
Some people just want too much, little hint for the future: If you want a smooth refined ride, don't buy an off road vehicle...
--

Lettuce spray for whirled peas...

Reply to usenet[at]miknik[dot]co[dot]uk
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Replace the tires. At 33K, I just replaced my OEM Generals with new Generals and the ride difference is very noticeable. Also, there are several different spring sets available on the ML. I can't remember how to identify which set you have (and it was luck of the draw - not a selectable option) but some are designed for ride comfort and others for handling loads. A deal *may* be able to help.
--

- RODNEY



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Any help out there? I have a 2001 ML320 that will occassionally emit a kind of "thunking" sound and then display yhe ABS & ESP lights on the dash. If you stop the vechile and restart, the lights turn off. There is no consistency as to when this happens. Any input would be appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi,
I had exactly this problem on my ML320. The problem was a faulty wheel rotation sensor on the front near side. They are (apparently) responsible for applying the brakes in case you loose grip. I got them replaced at no cost by my local MB garage.
HTH.
--
David



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the info! Was yours still under warranty? Mine is out, and I have a problem with my MBD getting it right the first time that I take it in. Thanks, Stan

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.