ASR Problems

I have a 93 600SEL that has been at my local MB shop more then I have been driving the car. The problems I am having with the car is the ASR light keeps coming on the
car starts ok idles just fine but when you give it gas in park the ASR light comes on and the car loses all power, I can put the car in drive and give it a little gas and it will go but don't attempt to take it over 30 or so MPH and the ASR light will come one and you have to put the car back in park restart the car and start over again. I have had the car in the shop 10 diff times and at 3 diff places and no one can fix it, I even took it to the dealer and they only wanted to keep changing parts the ASR computer, Injectors, Trans (yes they had me install a new TRANS in the car that was almost $5000.00) and still car doesn't run if anyone has any ideas on what I should do other then sending the car to the NAVY for target practice let me know thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The rarity and complexity of this model is part of the problem, IMHO. Other, more common, models have a relay called the "over voltage protection relay" that sometimes causes the car to exhibit strange behavior. Suggest you ask someone competent to check if your car has one of these and if so, whether it's defective.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Most common ASR fault is CTP [ closed throttle switch] or brake light switch.. Have the ASR module scanned for codes..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Been there, done that..... you need a new engine wire harness.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
This is a throttle control Unit problem, The car is going into " Limp Home Mode" > Type in Limp Home Mode under Google and you will get a site that explains all. I just p[aid 1700 to get replace. Part is 1200 US you can buycheaper at Performanceproducts.com. Hope this helps

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.