sl500 installing new sound system...now electrical failures

hi! sl500 getting new single cd/ radio, new speakers, s12 woofers in trunk, cd changer...from reputable third party installer. sound done but the soft top and the windows are not electrically responding to
'buttons'...not working. fuses are checked out, none blown. any ideas?? car now held up at the installers so they can keep trying or else will have to go to benz dealers...hoping something simple but do not have wiring diagrams. thanks in advance!!! new grad upgrading mom's car!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

From what it sounds, it appears that the buttons or canbus (assuming it has it) has been disconnected somewhere. If the door controller has been disconnected then windows wont be in operation.
Same applies to the centre consoles. Have the panels been replaced with the cables connected.
For my money I would like to see a 3rd party installer with a Benz diagnostic unit to see what is and what is not connected. Interestingly it is much quicker and easier to find mistakes that way. Most installers just rub their hands with glee .... make promises accordingly.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
big mistake messing with wiring in MB...got burned twice before MB finally got rid of junk stock Becker and went to Bose in the 97,98, 01 SLs I had and the H-K I have in my new 04 E500 4Matic is GREAT...I had a 98ML55AMG with a good Bose...but aftermarket in MB is a tough thing to do...I had an 87 560SL that was damn near ruined by top notch sound shop....no answers-sorry-you are in quicksand

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.