U.K. V200 Central Locking not working (longish Post). U.K.

I hope someone can point me in the direction of finding a solution, I suspect taking it to a dealer or similar may result in them spending a lot of time going round the houses finding the fault and maybe replacing modules
that do not need replacing.
The V200 is the people carrier variant of a Vito Van. It is fitting with a wheelchair lift for use by a severely disabled relative, when she is entering or exiting we need to unlock all the doors to gain access and strap down.
The locking has always (from time to time) locked and unlocked a few times when locking. I had assumed this was a door actuator not providing the appropriate feedback to the CL (Central control locking module), cleaning the contacts at the front of the sliding rear doors sometimes eliminated the problem. One day when were taking relative somewhere and unable to stop it happened a lot then stopped after which central locking did not work. Under some circumstances there is a clicking from the dashboard (low level) but nothing from the doors.
Key in drivers door has not effect.
Radio remote keyfob will make hazard lights flash but will not lock or unlock vehicle so at least part of that circuitry is working. Not sure whether alarm is working.
I have checked fuses I believe to be associated with the central locking and not found any blown but may well have missed one.
I have WIS on my computer but have only just started using it and do not find it easy to browse.
Any one any ideas what I can look at/for ?
If it is the central locking control module what is the likely cost of replacement?
Many thanks
David
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.