Fiat Punto 2001 mk2 sudden power loss - still not solved

Hi, I have a Fiat Punto mk2 2001. After a DIY engine oil and oil filter change, the car was not running smoothly and after a day or two we experienced loss of
power. It is very noticeable when accelerating from stationary or when going up a hill, it is literally without power. We took the car to our trusted mechanic who at first thought it might be a blocked catalytic converter since we noticed that I had put a bit too much oil (only did maybe 50Km with the extra oil in) and that upon being burned it might have helped the catalytic converter to get blocked. However upon loosening the exhaust manifold to bypass this, the car still remained with the same lack of power symptoms. He therefore then tried getting a set of coils (second hand for testing) however upon trying them, the issue was still present.
The ECU is not giving any faults, and upon checking the petrol pump pressure it was a bit out of range and it was replaced with a brand new one, however the problem still persists. He did compression test and values seem fine, we even go the injectors cleaner however to no avail.
We are totally lost on what the possible reason might be. The parts and time spent trying to solve this issue are now quite heavy and before just scrapping the car and paying the bill for the parts, I would really like to ask you if you can think of any other possible solution. Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi, I have a Fiat Punto mk2 2001. After a DIY engine oil and oil filter change, the car was not running smoothly and after a day or two we experienced loss of power. It is very noticeable when accelerating from stationary or when going up a hill, it is literally without power. We took the car to our trusted mechanic who at first thought it might be a blocked catalytic converter since we noticed that I had put a bit too much oil (only did maybe 50Km with the extra oil in) and that upon being burned it might have helped the catalytic converter to get blocked. However upon loosening the exhaust manifold to bypass this, the car still remained with the same lack of power symptoms. He therefore then tried getting a set of coils (second hand for testing) however upon trying them, the issue was still present.
The ECU is not giving any faults, and upon checking the petrol pump pressure it was a bit out of range and it was replaced with a brand new one, however the problem still persists. He did compression test and values seem fine, we even go the injectors cleaner however to no avail.
We are totally lost on what the possible reason might be. The parts and time spent trying to solve this issue are now quite heavy and before just scrapping the car and paying the bill for the parts, I would really like to ask you if you can think of any other possible solution. Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.