96 Jeep kills if I don't keep foot on gas pedal after a cold start

I have a 96 Jeep Grd Cherokee Laredo, 4.0 6, recently when I go to start it inthe mornings on my to work, it won't start, or maitain an idle unless I
keep my foot on the gas. I have to keep my foot on the gas pedal, and brake at the same time to put it in gear, or else it shuts off. Ther is no Ck Eng. light on. I have chgd the distributor, I keep gas treatment, and use fuel injection cleaners regularly. I don't want to spend an arm and leg on repairs that don't fix the specific poblem. Can anyone help??
--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/jeep-cars/200601/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On the XJ 4.0L there is a idle motor and that along with the throttle body might need cleaned.
JoBo

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Jo Bo did pass the time by typing:

http://revbeergoggles.com/tb/tb.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Another set of pix before and after cleaning the Throttle Body. http://www.imagestation.com/album/?id !22181169
I neglected to take any pix during the cleaning.. <sigh> GumOut Jet Spray and an old toothbrush cleaned it right up.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.