Ford Focus 1.6TDCI with pulsing revs

First of All
Hi Guys it has been a long while since I was last on here (when the german uni? stopped offering free access)
Now, as ever I need a little help.
I have a mk2.5 Ford Focus 1.6TDCI 109 (the french engine) the car is one of the few on a 08 plate (most are 58 onwards)
The car has always had a peculiarity in that on a run, when up to temperatu re it will have a period of loosing power for 2seconds before recovering, t his usually is accompanied with a puff of white smoke. When in this mode it will smoke steadily on the over run, or on tick over. Left alone this usua lly clears itself after 2-5mins and normal service is resumed. The smoke sm ells very dieselly.
Ive always put this down to a regen taking place.
Now the car has another issue where it seems suffering with a similar surgi ng/drop in power but pretty much all the time. If I run it in neutral at ab out 1700rpm, where the turbo starts to kick in I can hear a rythmic dull th ump then the revs drop slightly and the turbo whistle changes tone, before a second or so later everything goes back to normal. I have noticed this on a few occasions.
On this occasion There is a wee bit of smoke, but the engine was VERY cold and battery quite low so I dare say the glow plugs were not running at thei r optimum.
Any offers on what is going on here? EGR?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.