1987 300D A/C just quit - anybody have a schematic?

Was driving the other day and it just suddenly quit and started blowing ambient air.
Got home and tried listening for the compressor engaging when I
dialed-up 'max cool'. No clutch click. Checked pressure - don't see anything in the sightglass because there's no flow but I have >140PSI in a hot system - it SHOULD be enough pressure for the cutout sensor. Fuse (#7) is okay because the blower runs.
I don't have my metering handy so I can't start electrical checks for a couple of days. There was oil the last time I burped the high-side connector - looked reasonably clean. No visible leaks - I shouldn't have lost any oil. Had UV tracer in it from last year and I see nothing under UV light. Can't add oil or tracer now since I can't get a pressure drop. It's an R12 system, with a rebuilt R134 compressor, running 'Freeze-12' refrigerant (which is good for both '12 & '134 systems & seals & pressures & oils). http://www.freeze12.com & http://www.freeze-12.com
My Haynes book sucks when it comes to A/C - you can tear down brakes & steering & suspension and do other things that can kill you if you've screwed up, but they say A/C is dangerous black magic and should only be done by pros. Not even a schematic. F-'em.
Any help greatly appreciated. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.