2000 Nissan Sentra transmission issues- is the PCM/TCM toast?

This car I recently bought with a few minor issues but the transmission see med ok, shifted normally, had good power on acceleration, overdrive could b
e turned off and on, etc. Now the OD light won't come on, and the car seems to be pretty well stuck in limp mode. No matter what gear I select i won't downshift or upshift. Transmission fluid is pink and doesn't smell burned. I am able to connect an OBD reader to the port and read check engine codes which the only one I have is P1140 which I believe to be caused by a defec tive intake camshaft sensor which only really affects advancing the timing. I have tried in vain to get the OD light to respond to the button on the s ide of the gear selector. I have also tried getting the diagnostic mode to come on as detailed in the FSM but I have not had any success at all due to the fact that the OD light won't come on anymore. I know where the ECM is (passenger firewall) but I guess I am begging for help and experiences from others who have run into this issue. The fact that I can't get the OD ligh t on means there is a broken wire or a broken control module I am guessing? Just any advice please from people who I'm sure have more experience that I do. Thanks so much!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.