Anti-pollution Fault Peugeot 807 reg no 53 plate

I have a 53 reg plate Peugeot 807 that has started displaying "Anti-pollution Fault" from time to time over the past year. I do not want
to go to a main dealer but prefer to use my regular trusted independent firm instead.
The first time it happened a sensor (not sure exactly which one) associated with exhaust emissions was changed and this worked for a few months.
The second time it happened, together with a turbo charger low pressure diagnostic fault code, the "serum" in the emissions particulate filter system was topped up as it was low and a vacuum diaphragm associated with the turbo charger was found to leak and was changed (the mechanic used an internet forum to find the leak. A computer controlled regeneration cycle was performed. This worked for about 1 month but the fault is now back on the dashboard display with the engine management light on and the running in "limp mode" with reduced power.
I am not expert with the fault codes or the exact bits that were changed but remember being told about it.
The diagnostic faults read from the engine management on board computer are: P1435 Additive system and P0235 Turbo pressure sensor.
I phoned another independent Peugeot specialist but he could not take this on and recommended I use the main dealer as it is a known fault on this car. He guessed I may need a new particulate filter. I prefer to let my independent man have another go and he will consult with someone at a main dealer for me as he has always been good to me over the years. He may attempt to clean the particulate filter.
Has anyone got any ideas as the car seems fairly unreliable.
Thanks
Graham
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.