flaky bluetooth phone - Samsung A900

the Samsung A900 is apparently crippled re bluetooth functionality as it cannot upload phone book to Prius, and has a bug where it generates
phony incoming call notifications when crossing cell boundaries.
So, I have taken to leaving the Bluetooth off on the A900.
But, when I do decide to use it, there is another annoyance that I cant figure out: if I dial on the A900 the Prius will connect via bluetooth ok, but may or may not play the audio through the speakers, sometimes it starts playing the audio and then turns it off and I have to pick up the phone, or it may not play the audio at all even though it dials ok.
is this another A900 bug or some weirdness with the Prius bluetooth operation?
is there a good quick online howto guide to using a bluetooth phone on the Prius?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
This sounds like a phone problem. I have an Ericsson T616 with Cingular service and I have not experienced anything like that with either my 2004 or 2006 Prius. I have also heard that some cell phone providers cripple the bluetooth on their phones because they are trying to sell equivalent services. I Googled Prius+blutooth when I first got my car and didn't really find much that was helpful. I got mine going using my phone manual and the Prius Owner's manual.
Kari

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.