bad mold smell from 1997 Honda Accord AC

I have over 200K on my 97 Accord. I recently had one of the valves replaced on the AC unit where they removed the evaporator. They found
a ton of mold in the evaporator case and cleaned it out with bleach. I always did often have a mold smell come out of the AC when it started up for a few minutes. Now after the recent AC work, the mold smell is worse yet still only is apparent for the first 10-20 minutes of driving. My mechanic said nothing much can be done. He sprayed some of that mold fighting aerosol into the evaoporator without much luck. I have been turning off the AC and putting it on fresh air a few minutes before my destination, although again the improvement is only slight. Is there any other thing I can try to help fix this problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Does your model have a cabin air filter? If yes, have you changed it?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@yahoo.com wrote:

--------------------------------------
There's a ton of stuff you can find through Google including a delay timer / fan that was introduced on some American cars (years ago) that dried it out every time you shut the car off. Many creative solutions. Hope you find something.
'Curly'
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.