Imy 2000 model Deawoo lanes sportshatch auto won't idle

Deawoo lanes sportshatch 2000 model auto 90,000km won't idle, timing is perfect, spark plugs & leads fuel pump replaced . It starts with constant spraying of
"start ya barstard" for about 30 seconds then splatters & stops . Any suggestions? Fuel injectors maybe?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Deawoo lanes sportshatch 2000 model auto 90,000km won't idle, timing is perfect, spark plugs & leads fuel pump replaced . It starts with constant spraying of "start ya barstard" for about 30 seconds then splatters & stops . Any suggestions? Fuel injectors maybe?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If timing is good and spark is good (and even if something other than the plugs and wires were bad you'd have noticed a spark problem with the timing light I hope), then it's exhaust, fuel, or air.
Does a noid light come on when you look at the solenoid outputs? Is there a massive leak in the air plenum? If you measure fuel pressure at the rail, is there any?
The fact that it needs starting fluid indicates that it's not getting fuel. --scott
--
"C'est un Nagra. C'est suisse, et tres, tres precis."

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Natasha Mckenzie wrote:

Vac leak.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wednesday, April 11, 2018 at 4:18:06 AM UTC-10, Natasha Mckenzie wrote:

Check your idle air control valve. If it runs fine once it's warmed up, check your cold start valve.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.