1999 Chevy Suburban - Feels like its all over the road!

I am a newbie and recently purchased a '99 Suburban K1500 and it feels like its all over the road. I am always correcting it even when going straight.
Does anyone else have that problem? I already checked the tire pressure in all tires, but it still drives the same. Any help would be appreciated.
Thanks, Wayne
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the steering and suspension for wear or free play in the linkage.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Yes and if tight, have alignment checked. Be advised that if it has never been aligned that there will be a extra fee to remove some knock outs in upper control arm to allow for alignement adjustment. I had my old style 2000 K3500 aligned last year and it took a couple of trips back for them to get it right. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had that for over a year. My tires were bad, messed up belts, and the front end was a nightmare for the mechanic to straighten out. Now it drives very nicely. Have your tires, suspension, and alignment checked.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.