2000 Silverado starting puzzle

Hi guys, Haven't been checking in here for quite awhile, but now have an issue I didn't see brought up already that's exactly like mine. There's been other
"no start" posts but mine is confusing. I have my "message center" blinking at me with various warnings now, along with an ABS light that comes on after several hundred feet the majority of the time ( ABS stopping prob. recall already done - this one does NOT affect stopping, ABS function, etc...) but, that's another problem. What's happening now, along with the bouncing gas gauge/low fuel message, is my SECURITY light will come on after starting the truck and stay on. So far, it hasn't changed the operation of the truck while driving, but now I'm wondering. Every few days, the truck now refuses to start (no security light on). It seems to catch, but as soon as you release the key, it dies. You can do this 50 times with no sputter or indication it wants to keep running. Then, after sitting for several minutes, it will fire and run smooth like no problem. No smell of fuel or smoke. No stored codes (for anything; ABS, fuel gauge or security) show up. Suspicions are the security system (does it cut fuel?), lack of fuel (pump finally cutting out - but why never once it starts?) or ignition cut-out (but it does kick and act like it's running until key is released). Any help would be appreciated, since it's making me second-guess my 30+ years loyalty to Chevys. PS: My son, a BMW tech, thinks it might be a crank sensor hit or missing?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
GaryG wrote:

I have a 2000 Silverado Z-71 5.3 Ext Cab with a ' on/low fuel' gage text problem. By shifting to Neutral twice from drive turns the message 'low fuel' off and lets the fuel gage needle rise to the correct position. I may have a steering column wire going bad or worn thru??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 2000 started doing some of those things and it was still under warranty. They replaced the ignition switch and I never had the problems again.
Hope this helps.
Karl

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Something similar a few months ago. My thermostat was bouncing all over. Truck would try to start but as soon as stop turning key nothing. Found I had a exhaust manifold gasket crack and was losing anti-freeze. when this occured I was told there is a sensor in rad that sees the level. Did not make alot of sense to me since after 5-10 minutes it would just start fine but fixed gasket and added fluid and never had problem after. Might be worth checking but your sounds a little different but my truck did weird things to.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.