89 Chevrolet Blazer 4.3 4X4

While driving it almost feels like its going to cut out looses power really quick but then it comes back. Does this to anyone sound like it may be a fuel issue or perhaps a transmission issue?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sounds like a bad main ground (battery negative to engine block) or main positive (battery positive to power distribution block).
Doc

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'd also check out the MAP sensor, and basic tuneup items.
I had a problem that sounds very much like what you describe-- ended up being poorly-crimped spark plug wires that, over the course of 15K miles had vibrated loose on the distrib end.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wait a minute...just had to replace my distributor cause the bushing on shaft went south...It's just a guess but the motor ran like crap..grab the top and see if it wobbles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Does your check engine light come on?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The check engine light doesn't come on
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.