Cruise control

How can I tell for sure I have these two options;
My trucks indicator lever has both wiper delay, and cruise control. Neither of which work. I have to manually stop my wipers by holding them on mist, and letting go
when they are out of the way, and the cruise control shows no sign of working at all.
My best guess - it broke on the previous owner and he put in one with all the fixinz
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Since you didn't say what year, I'm giving you the advice for trucks I know (73-87)
Cruise: follow the speedo cable. If it goes straight from the transmission/transfer case to the firewall, you don't the rest of the guts for the cruise.
Delay: (73-81?) Check the plug on the back of the switch. If it goes into a module then into the wiring harness, you have delay, if not you don't. (82? - 87) If there is an electronic control module attached to the bottom of your steering column that when unplugged makes the wipers stop working completely, then you do, if not, you don't.
Again, not knowing what year you've got, makes it hard to advise.
Jeremy

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'm usually better at that.
1985 chevrolet k5 305cui th700r4

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Cruise control Group: alt.autos.4x4.chevy-trucks Date: Sat, Oct 25, 2003, 12:13am (CDT+5) From: snipped-for-privacy@REMOVEworldnet.att.net (KJ) How can I tell for sure I have these two options; My trucks indicator lever has both wiper delay, and cruise control. Neither of which work. I have to manually stop my wipers by holding them on mist, and letting go when they are out of the way, and the cruise control shows no sign of working at all. My best guess - it broke on the previous owner and he put in one with all the fixinz
What kind of truck and what year???????? Steve C
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Always remember we are all Ms.CLEO's, we dont need MAKE, MODEL, YEAR info
Wipers, the arm is marked for delay but only has OFF / Low Speed / High Speed ?? I'd say the Column (or handle) was swapped at an earlier time.
Is there One, Two, or Three cables at the Carb/ TBI ?? 3 cables and automtic follow the cables. one is probably a cruise cable.
Two cables Automatic ,,, probably not a Cruise on it Two cables on a Manual... probably a cruise
one cable,, no cruise.
NOW contav=ct WWW.Bought4Less.com and get the Correct handle and Cruise Control for that truck
: How can I tell for sure I have these two options; : : My trucks indicator lever has both wiper delay, and cruise control. Neither : of which work. : I have to manually stop my wipers by holding them on mist, and letting go : when they are out of the way, and the cruise control shows no sign of : working at all. : : My best guess - it broke on the previous owner and he put in one with all : the fixinz : :
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.