Doc? Anybody? '92 4x4 s10 Blazer 4.3 temperatue sensitive code?

"92 s10 keeps throwing knock sensor codes but only when the engine is cold. I replaced the knock sensor with one I got at Auto Zone and checked the
voltage at the connector, I got 3.9 volts, would that cause the computer to throw a code? The colder it is the longer the service engine light stays lit. Then it will come back on the first time the thermostat opens until the engine reaches full operating temperature. Help! I'm lost here. No one seems to be able to figure this out.
Any help, or suggestions (other than high explosives) woud be a big help.
Thanks,
N.M.W.B.A.o.O.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
message

Where is your base timing set?
Doc

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sorry it took so long to get back to you, Wifey's been a little under the weather.
The timing seems to be about 1 before TDC. When I had it tuned the mech said it was within tolerance and shouldn't affect anything. Was he shining me on?
Again, Thanks,
N.M.W.B.A.o.O.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
message Sorry it took so long to get back to you, Wifey's been a little under the weather.
The timing seems to be about 1 before TDC. When I had it tuned the mech said it was within tolerance and shouldn't affect anything. Was he shining me on?
Again, Thanks,
N.M.W.B.A.o.O.
////////////////////////////////////////////////////
You did disconnect the EST wire before checking the timing right?
Anyhow, bump it to 4*BTDC and see if the light shuts off. If that doesn't work try 6*BTDC, but don't go any higher than that.
Doc
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
OK, Doc. I'll give that a shot and see what happens. And, yes the EST wire was disconnected when the timing was checked.
Thanks for the quick response,
N.M.W.B.A.o.O.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.