Engine corrosion caused by Chevy?

I have a 1997 Tahoe with 5.7L engine and only 87,000 miles on it. A couple of years ago my mechanic discovered a rust covered sludge when he took off the radiator cap. That cost me a new radiator and he
warned that the intake manifold gasket would probably need replacing. Last week we took the Tahoe in for what appeared to be a heating problem and he discovered a bunch more sludge again. He went ahead and flushed the system, but said that the problem stems from the original coolant that Chevy put into the engine on 1996 - 99 vhehicles. The coolant turned out to be bad and is embedded in the walls of the engine. The engine walls will continue to corrode and there is nothing I can do about it. He suggested we trade the vehicle off while it still runs good. He also said that Chevy has taken no responsibility for this problem
Has anyone else heard about this "bad" coolant? What did you do about the problem?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's the Dex cool ... We flushed ours out with water a few times then a cleaner just don't leave in too long then flushed with water a few more times and no problem. I think most of the "shit " you see in there is actually the anti freeze breaking down. Can anyone on here correct me if I'm wrong, but I don't think it's actually eating away at the cast iron.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Not exactally. THe problem stems for the mixed alloy engine assembly and the galvanic reaction set up by coolant contacting aluminum and cast irn parts. Dexi was GM's attempt to deal with this at a 50/50 consentration but it can have problems over time as coolant breaks down. I found long ago that if you run 60/40 or better you will not have any problems at all. I run 70/30 and my 2000 K3500 is clean as new and overflow tank is spotless. Even my 89 that I bought new and that has had around 70/30 of conventional antifreeze since new is spotlessly clean too. Water is very reactive and the less of it the better at times. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Don wrote:

First off and saying it with no malice your mechanic is an idiot. The crud you are seeing is NOT rust and is NOT due to corrosion of the engine. From your description I would say that your getting air into the cooling system which is what is causing the goop your seeing. The Dex-cool breaks down and gels up when it gets air mixed into it. Nothing to do with the engine design and it is NOT corroding the engine. Sounds like your mechanic is hoping you trade in the area so he can go buy a low mileage truck for a good price.
If you are that worried you can have the system flushed and filled with the older green coolant, then you just switch to a 3 year cycle of flush and fill.
--
Steve W.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had the same problem with my 98 Blazer. When I removed the radiator cap it was a solid brownish sludge. Kind of looked like it was filled up with putty. Anyway I flushed out the system with cleaner & refilled with good old green & it was fine after that, until fall came around & I had no heat in the truck. I once again flush out the system with cleaner & refilled with old green & it's been about 2 years now & its been fine. Duke
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.