heating and ventilation

After couple of hours of runtime my 98 Chevs Truck heat and/or AC doesn't actually blow heat or air. Fan is working but desired affect is not achieved. Blower, motor and the
comutator are brand new, and still have a problem. When the truck is shut off for 15 min, then started all is working good, but will still malfuntion after a couple of hours. Please advise.
snipped-for-privacy@cablerocket.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Blower resistor...Its located near the fan motor...Pull it .....Change it... Steve C heating and ventilation Group: alt.autos.4x4.chevy-trucks Date: Sat, Oct 25, 2003, 6:31pm From: snipped-for-privacy@cablerocket.com (bogdan) After couple of hours of runtime my 98 Chevs Truck heat and/or AC doesn't actually blow heat or air. Fan is working but desired affect is not achieved. Blower, motor and the comutator are brand new, and still have a problem. When the truck is shut off for 15 min, then started all is working good, but will still malfuntion after a couple of hours. Please advise. snipped-for-privacy@cablerocket.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is it after running the heat or AC that it gets blocked up? I have a problem on my '97 where when the AC runs for 1.5-2hrs straight, I hear this slight ssssssssssmmp, then nothing blows. Fan is working fine, but it's like the airflow is blocked somewhere, shutting off the AC for 15mins clears it up.
bogdan wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.