Acura vibration

I need help solving this problem. I have an 03 Acura CL type S. It has 52,000 miles. Recently I began noticing back and forth vibration in the steering wheel. This only happens when applying the brakes. As the car
slows to approx. 35 MPH the vibration begins. Gets bad at 30 MPH. Stops vibrating at 25 MPH. I've balanced and rotated the tires. I've replaced the front brake pads with ceramic. I've replace the front tires with Michelins. Nothing has changed. Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check front brake rotors....sound like warped.
does this happen when you coast in neutral to a stop?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No, it is rock solid when coasting. It only vibrates when braking between the speeds of 35 and 25. I will check the rotors today.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 2/4/06 8:41 AM, in article snipped-for-privacy@localhost.talkaboutautos.com, "Trudytudy"

You should also check the upper ball joints. My 2000 did this once and the problem was a failing upper ball joint.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sat, 04 Feb 2006 09:41:36 -0500, Trudytudy said:

If is was the rotors, it would vibrate really bad when applying the brakes at higher speeds.
--
"I refuse to answer that question on the grounds
that I don't know the answer."
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I pulled the rotors and had them resurfaced. They were not warped or in bad shape, but it fixed the problem. Thanks for the help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have you had the front end alignment checked?
This solved my shaking problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
DQoiQS5Ob255bW91cyIgPGFub255bW91cz4gd3JvdGUgaW4gbWVzc2FnZSBuZXdzOmRfT2RuUjZE YmZZLU00M1puWjJkblVWWl92LWRuWjJkQGJyaWdodC5uZXQuLi4NCj4gSGF2ZSB5b3UgaGFkIHRo ZSBmcm9udCBlbmQgYWxpZ25tZW50IGNoZWNrZWQ/DQo+IA0KPiBUaGlzIHNvbHZlZCBteSBzaGFr aW5nIHByb2JsZW0uDQoNCk5vdCBpZiBpdCdzIHNoYWtpbmcgLyB2aWJyYXRpbmcgd2hpbGUgc3Rv cHBlZCBhdCBpZGxlLiAgOi1QIA0K
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.