really rough idle?

driving home tonight my 2003 A4 quattro 3.0 v6 started a REALLY rough idle and didn't have much power... like it wasn't firing on all 6 cylinders... I
got it home and smelled something like plastic melting.. I popped the hood and could see something that looked like a fitting on the end of a metal tubing GLOWING RED HOT. It's on the right side, towards the firewall, and down lower than the spark plugs..
of course I just got it back from the 80k miles servicing yesterday where the dealer tried to tell me I really should have the timing belt changed... I refused it..
ugh, I think they jinxed me.
any ideas? Troy
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Shagster wrote:

You would be dreaming about a minor problem like you just described if your timing belt snapped. You are driving on borrowed time.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Shagster wrote:

Why did you refuse it? Seems like the dealer was giving you good advice.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
because I didn't have $1500 to spend on it and the "certified maintenance book" doesn't call for it until about 110,000k miles..

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like a coil pack failing. Idle and smell were that same on my 2003 A4 2.0l.
Dealer replaced the full set under warranty which was then about 2.5 yrs old.
--
Mike Mitchell



Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
failed ignition coil pack it was! $36.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.