94 740IL has problems starting - vapor lock?

Lately my 94 740IL has been having problems starting. It didn't start for 2-3 days over last weekend, started and ran fine Monday but hasn't started
since. All the electrical systems in the car are fine, the battery is fine, no other issues going on. Funny thing is, when I drive to work and it won't start at the end of the day, if I wait 20-30 minutes it starts right up, which leads one of my co-workers to think it could be vapor lock. I've only had this problem when the weather is 75+. Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gitrdone.org wrote:

Vapor lock is a non-issue in fuel injected cars. I'd be checking my temp sensor.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Oh no it's not. I have an EFI V-8 (not BMW) which suffers badly - but only when you attempt a hot re-start on a very hot day. It will eventually start on a couple of cylinders and come good after some time. But unlike a carb car where you have to re-fill the carbs after evaporation for a cold start the injection makes this instant because of the pressurized fuel rail

But I'd say you're right it's not the reason in this case.
--
*Am I ambivalent? Well, yes and no.

Dave Plowman snipped-for-privacy@davenoise.co.uk London SW
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

When my 635 did this it was a combination of bad relays and dirty wiring. First thing I'd try is a new fuel pump relay.
--
Who needs a life when you've got Unix? :-)
Email: snipped-for-privacy@unixnerd.demon.co.uk, John G.Burns B.Eng, Bonny Scotland
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

for
started
fine,
won't
only
Agreed. Probably a bad solder joint or component in the relay. I've seen this on several E28/23/24 models.
JB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.