Bad Gas?

I have a 99, 3.8 Camaro with 53,000 miles. I have had no trouble with the car at all since I bought it 2 years ago with 27,000 miles. Yesterday I drove it all the way down to empty. I stopped a different gas station than
normal and bought $10 gas. After buying gas I drove one mile to the store and stopped for 10 minutes. When I came back the Service engine soon light came on and now the car is running VERY rough, loss of power and has a bad shudder to it when idling and am accerlating. We have had a lot of rain this past week and I am wondering if there is water in the gas I bought. Has anyone else had this problem? Can I just put something in the gas? I really can't afford to go to Mr. Goodwrench. Any help or suggestions would be helpful. Thank you
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had that problem with mine, Ive tried two different things and i dont know which worked but it runs good now. got Dry gas for $.99 at Wal-mart and got some Octane Boost. Used both with a full tank of gas and about 2 miles later was running hard and strong.
worth a shot and there a hundred different types of Octane Booster. I use Outlaw, no reason behind it just more convnient in 4 packs to save in case i need them again.
Jamie

than
light
would
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Where is the filter? I assume it's the same place on a 2000. I have a similiar issue and will prob change mine...if I can find it.

the
store
bad
I
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
duuude.

I
rain
bought.
gas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.