Berlingo Lumpy

I have a 2.0 Hdi Berlingo van that is very lumpy when travelling at 30mph in 3rd gear. It is an 03 model and it has just had it's 38000 mile service. It has stalled on occasions at junctions, just as you are
about to go. Is this a common problem? The dealer said there was nothing wrong!
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I used to have a HDi Berlingo for a company vehicle, but stalling at junctions on mine was caused by the EGR valve, the accelerator potentiometer was also replaced. You may also experience a big loss of power and revs limited to 2500 with the engine warning light on.

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Fri, 10 Dec 2004 14:17:16 UTC, snipped-for-privacy@gdtfire.com wrote:

Another common (and simple) problem is the clutch sensor switch (situated at the clutch pedal) - if this doesn't work right, the HDi will stall when stopping at traffic lights, shiftig gears etc.
HTH Hartmut
--
Please use 'Reply-to' for personal e-mail.
Bitte fuer direkte emails 'Reply-to' benutzen.
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.