2005 Ram 1500 hemi lifter noise anybody?

I have around 29,000 miles on this truck bought new. I started noticing lifter noise at about 8,000 miles.
It isn't real bad right now, but my 3 year/36,000 mile bumper to bumper
warranty will expire by the 28th of Feb.
Has anyone had this problem?
I also have had the cruise control engaged & when using the decel button, had it completely turn off cruise control, is that normal?
One more thing: Had both front doors re-weatherstiped as they were leaking into my pillar door grasps. Now the drivers side is doing it again (when it rains or snows.)
other than that, I love the truck! the Quad-Cab is pisser! I am still on my first set of original tires, that so quiet on the highway! Not great in snow, but livable!
So!
I'm curious, if anyone has experienced any of the above problems that I mentioned.....
Due to E-Mail spamming bots my reply address is incorrect.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

<snip>
i don't have any specifics but i have seen two late model rams with hemis at a local shop that had the manifold/plenum pulled off the top and the wrench said something about bad cams on both. i believe both were under 50k miles but am not sure nor what the cause was.
i just did a google search on bad camshafts for late model hemis and nothing jumped right up. maybe i should start this thread down the toilet and say it must be due to that no account synthetic oil that folks are using, or was that dino oil, or was it the lack of oil? something to that nature... ;-) michael
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yak!
I just set up a service appointment. Of course the first thing they asked was... are you using 5-20 weight oil!
I told them that yes I have, they said if you don't use 5-20 weight oil it will cause that problem...
I felt that, if that were so, all of my lifters would be making noise!
I am running synthetic oil on that beast after I did about 12,000 miles on it. I don't believe they know what they are talking about...
If all lifters were cranking out a tune, then I would say they may have a point! :D
& of course the ball joints are going now too! Thank God for the 3 year 36,000 mile warranty!
Say! Thanks for looking up the info on the plenuim/camshafts! I'll have to ask them about that when I go in to the shop on 2/20/08!
I'll let you know what they let me know, as soon as I know what the hell they are talking about.... :D

Due to E-Mail spamming bots my reply address is incorrect.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check & see if you can find anything on Hemi valve springs
-- Message posted using http://www.talkaboutautos.com/group/alt.autos.dodge.trucks / More information at http://www.talkaboutautos.com/faq.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 25 Feb 2008 02:01:57 -0600, "sqdancerLynn"

Thanks, I'll do a search.
Due to E-Mail spamming bots my reply address is incorrect.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 25 Feb 2008 02:01:57 -0600, "sqdancerLynn"

I looked at your link, surprised me that they mirror this news group. I'll need to be careful as to what I say for now on, as it will be searchable via "Google" or any other search engine.
I'll have to Google myself with my user name & see what shows up. I did that with my real name & only saw two items & both didn't make me look like some dope.
I have heard that future employers will search a persons name, to see if they are of "good character" Ya got to love/hate the internet......
Kurt
Due to E-Mail spamming bots my reply address is incorrect.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Well Michael it looks like it is the oil causing the lifter noise. I didn't want them pulling a oil analysis on my oil & maybe void the warranty, so... I drained 3 quarts of the 7 in it & added 3 quarts of 5W-20W in it. I ran it for around a hour to mix it up. Guess what? No more lifter noise, isn't that amazing?
The ball joints were ok, they said that the stops for the turn to turn needed greaseing, which I hadn't done, my fault.
Looks like all the problems were owner induced, dumb shit that I am.......
Kurt
Due to E-Mail spamming bots my reply address is incorrect.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Kurt wrote:

The Hemi Tick is a common complaint. Most seem to feel its just the nature of the engine as it breaks in. Some 2003 and 2004's did have incorrect valve springs installed which caused ticking and sometimes the springs broke.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Miles, has the "Hemi tick" been fixed by 2007? I've got a 2007 Hemi going in my '93 Ramcharger and just want to know what to expect. tia
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Well, if you are going with the 6.1 hemi you won't have that problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I thought about the 6.1, lots more power, lots more money and less fuel economy. None of that would have stopped me when I was younger, sigh...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I hear ya. I had one in the charger srt8, good engine, real ballsy, not that bad on gas on the highway 18 or so, but around town it was a killer. I couldn't justify it, so it went. In a ramcharger, I wouldn't want that gas bill.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
BigIronRam wrote:

Not sure about that. The tick doesn't seem to cause any problems. I know many with well over 100K miles on theirs and it's always ticked and no problems.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Miles wrote:

Sounds like the old 318/360 pinging problems.
Never seemed to matter to the health of the engine. Just drove some drivers crazy listening!
SMH
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

a member of my family owns an 06 quadcab with a Hemi.. they still tick.
-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Well, maybe, if I'm really lucky my hearing will deteriorate like my eyesight...damned old age...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

That's what the volume knob on the radio is for.<G>
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I thought it had to do with the cyl cut out.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Well, it has been about 15 days now & my lifter ticking is gone. My Bad! I'll need to stick with 5W-20W oil I guess, as much as I hate to be using that weight oil in the summer. But you do what you have to do, no matter if you like it or not.
I want to thank every one out here for all of the comments & advice. This is what I love about using the "usenet" groups!
There are not many of us that still use it, mostly the "old-Timers" from when the internet first got started for the public.
Ya got to love it!
Kurt
Due to E-Mail spamming bots my reply address is incorrect.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.