UPDATE 1999' RAM "Speed Sensor Malfunction"

I replaced the speed sensor today, using an identical one that I bought at AutoZone. Unfortunately, replacing it had no effect and the speed dial still acts erratically. It shows zero at low speeds, and
starts showing speed at high speeds (40+ MPH). Any clues?
i
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
When my speed sensor went bad, all the symptoms showed up at the same time. The speedometer read zero and the ABS and BRAKE lights came on. Everything was OK before that moment. BTW, I have a 99 Ram diesel 2500.
Did the new part fix the ABS & BRAKE lights? Perhaps the eratic speedometer is a different problem.
--
--------------------------------------------------------
Ed J edj22 at attglobal dot net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Exactly my problem!

No, I do not think so.
Thanks for sharing.
i
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Did you check to make sure that you don't have a second one on the transmission?
--
If at first you don't succeed, you're not cut out for skydiving


"Ignoramus32489" <ignoramus32489@NOSPAM.32489.invalid> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Um, that's the one that I replaced!
Is there a second one somewhere else?
i
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
rear wheel speed sensor is in the rear axle on top of the axle housing
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Oh, I see. I was looking at it today and wondering what it was for. How is it removed? There is no obvious threading there.
i

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It is held down by a single bolt and clamp.
--
If at first you don't succeed, you're not cut out for skydiving


"Ignoramus32489" <ignoramus32489@NOSPAM.32489.invalid> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks. What's the name of that item? Is it also called "vehicle speed sensor"?
i
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It is sometimes referred to as the RWAL speed sensor.
--
If at first you don't succeed, you're not cut out for skydiving


"Ignoramus14381" <ignoramus14381@NOSPAM.14381.invalid> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The output speed sensor in the trans wouldn't make the ABS/Brake lights illuminate, nor make the speedo fluctuate. It may set a code, but that's it.

You replaced the wrong one... in the previous thread, at least two of us told you it was the one in the rear diff. Hopefully the people at Autozone are friendly, and will take the incorrect sensor back.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Most auto parts store will not take back electrical items, at least not the ones that I worked at.
--
If at first you don't succeed, you're not cut out for skydiving


"Tom Lawrence" < snipped-for-privacy@earthlink.net> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Or just keep the old one as a spare.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I ordered the RWAL speed sensor from dodgeparts.com. The sensor promptly arrived today. Replacing it was easy, but a little uncomfortable. Could have been much worse with a different vehicle.
This FULLY TOOK CARE OF MY TRUCK PROBLEMS. No idiot lights are lit up. ABS, check engine lights etc are all gone and my speedometer is functioning perfectly.
Thanks to everyone for your help and guidance.
i
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just curious, how much would it cost me to fix this problem at a dealer, especially if I was not a well informed customer.
thanks
i
On Tue, 21 Jun 2005 03:21:34 GMT, Ignoramus16736

--


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Probably about $50.00 for the part and an hours labor.
--
If at first you don't succeed, you're not cut out for skydiving


"Ignoramus30369" <ignoramus30369@NOSPAM.30369.invalid> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.