windshield wipers

I have a 2000 Trans Am and the windshield wipers are starting to act weird. Sometimes I will turn them on and they will not turn on at all, at which time if I press and hold the WASH lever they will start
working, and then work normally.
Sometimes they will not start working in dalayed mode, but they will work in fast mode (and from then on, in delayed mode). Once I had them start working fine in delayed mode, then after a few minutes they turned themselves off by going into the OFF position even though the knob was untouched. I got them restarted by putting the wiper knob in FAST mode.
So, given this information, what do I need to get fixed/replaced with respect to the wipers?
Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

There is a circuit board that controls the function of the wiper motor. This board has been know to crack. Check with your local dealer to see if there is a recall out there. I had the same problem with my former 1992 Trans Sport (own since new). The fix was a new motor for $ 500 installed. However, after 11 years and 130K miles, it was the only part that ever had to be replaced beside alternator and water pump (that was a planned replacement.)
You can check to see if the ground to the motor is clean, the connector plug is clean. If the connections are no good, that can cause it to act up. If this checks out, then look to one of the big box auto parts place, or the mom & pop one down the street for a new motor.
Check the local bone-yard to see if they can get you one from their network. Its a simple motor with a cam. Its the electronics add to it that fail.
Post back with the outcome. Good luck.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.