1991 Ford Taurus

Need some help here i have a 1991 ford Taurus that is giving me a problem on acceleration. When i accelerate it starts to go then seems to choke like it is not getting any gas then it seems to shift and jerks and then
goes as it should the choking sensation seem to last a few seconds before shifting, This happens every time i make a complete stop then it drive likes it should if anyone could help me any idea on how to fixthis problem it would be appreciated
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Are you getting a service enginge soon light?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If your Check Engine lite is not on, and it starts okay, cold or warm; then warm up the engine and shut it off.
Locate the Mass Air Flow sensor (MAF), in the big air tube to engine, adjacent to the air filter, and disconnect wiring connector to it. Your CEL lite will then be on, but drive it and see if it does the same thing.
If it drives better, the MAF needs cleaning. If it runs worse, or wont run, there is another sensor problem.
Also check the throttle crank ... there should be two connections to it. (Three if you have cruise) One for gas pedal, other to transmission. If there's slop in either.. it will probably be the connection for the trans cable.
--
Yeh, I'm a Krusty old Geezer, putting up with my 'smartass' is the price
you pay..DEAL with it!
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Backyard Mechanic wrote:

Was not 1991 the first year for AXODE?
Bob
-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.