2000 Windstar OBD-II port dead??

I have a 2000 Windstar with CEL on. Plugged in an OBD II tool from Harbor Freight and it didn't turn on. Tried it on my '96 Contour and the tool worked, so I'm assuming the Windstar port is dead. Any ideas
on how to diagnose the OBD port on the Windstar and how to fix it? Haven't tried another tool, seems odd if the tool worked on the Contour it wouldn't work for the Windstar. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I can't seem to access the 00 Windstar wiring diagrams at this time but..... Pin 16 (looking at the DLC with the wide side at the top, pin 16 would be on the loewr left corner looking at the plug in side... wire is usually light blue with white trace) is hot at all times - usually fed by the same fuse as the cigar lighter...
HTH
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Aha, I'm glad you mentioned the cigarette lighter. The cigarette light next to the cup holder tray doesn't work. I didn't even think to check the fuses for the OBD port. l'll go home and try it. I bet you're right. The power point by the passenger's foot works, must be on a different circuit. Glad it's something simple if you turn out to be right! Thanks.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.